home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-fs / reiser4progs-1.0.5 / reiser4progs-1.0.5.ebuild < prev    next >
Text File  |  2006-01-09  |  2KB  |  61 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-fs/reiser4progs/reiser4progs-1.0.5.ebuild,v 1.4 2005/11/29 03:53:41 vapier Exp $
  4.  
  5. inherit eutils
  6.  
  7. MY_P=${PN}-${PV/_p/-}
  8. DESCRIPTION="reiser4progs: mkfs, fsck, etc..."
  9. HOMEPAGE="http://www.namesys.com/v4/v4.html"
  10. SRC_URI="ftp://ftp.namesys.com/pub/reiser4progs/${MY_P}.tar.gz"
  11.  
  12. LICENSE="GPL-2"
  13. SLOT="0"
  14. KEYWORDS="amd64 ppc ppc64 -sparc x86"
  15. IUSE="static debug readline"
  16.  
  17. DEPEND="~sys-libs/libaal-${PV}
  18.     readline? ( sys-libs/readline )"
  19.  
  20. S=${WORKDIR}/${MY_P}
  21.  
  22. src_unpack() {
  23.     unpack ${A}
  24.     cd "${S}"
  25.     # bundled libtool sucks, so rebuild autotools #74817
  26.     aclocal && libtoolize -c -f && autoconf && automake || die "autotools failed"
  27.     cat <<-EOF > run-ldconfig
  28.         #!/bin/sh
  29.         true
  30.     EOF
  31. }
  32.  
  33. src_compile() {
  34.     econf \
  35.         $(use_enable static full-static) \
  36.         $(use_enable static mkfs-static) \
  37.         $(use_enable static fsck-static) \
  38.         $(use_enable static debugfs-static) \
  39.         $(use_enable static measurefs-static) \
  40.         $(use_enable static cpfs-static) \
  41.         $(use_enable static resizefs-static) \
  42.         $(use_enable debug) \
  43.         $(use_with readline) \
  44.         --enable-libminimal \
  45.         --sbindir=/sbin \
  46.         || die "configure failed"
  47.     emake || die "make failed"
  48. }
  49.  
  50. src_install() {
  51.     make DESTDIR="${D}" install || die
  52.     dodoc AUTHORS BUGS CREDITS ChangeLog NEWS README THANKS TODO
  53.     #resizefs binary doesnt exist in this release
  54.     rm -f "${D}"/usr/share/man/man8/resizefs*
  55.  
  56.     # move shared libs to /
  57.     dodir /$(get_libdir)
  58.     mv "${D}"/usr/$(get_libdir)/lib*.so* "${D}"/$(get_libdir)/ || die
  59.     gen_usr_ldscript libreiser4-minimal.so libreiser4.so librepair.so
  60. }
  61.